Outage in Player
Incident Report for Angelcam
Resolved
This incident has been resolved.
Posted 6 months ago. Sep 18, 2018 - 08:57 CEST
Investigating
Our automated system has detected a possible outage in Player service. We're currently looking into the issue.
Posted 6 months ago. Sep 18, 2018 - 08:53 CEST