Outage in CDN
Incident Report for Angelcam
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 25, 2019 - 11:30 CET
Investigating
Our automated system has detected a possible outage in CDN service. We're currently looking into the issue.
Posted about 2 months ago. Jan 25, 2019 - 11:14 CET