Outage in Marketing website
Incident Report for Angelcam
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 17:24 CEST
Investigating
Our automated system has detected a possible outage in Marketing website service. We're currently looking into the issue.
Posted Sep 13, 2021 - 17:23 CEST