Outage in Arrow server for EU
Incident Report for Angelcam
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 09:37 CET
Investigating
Our automated system has detected a possible outage in Arrow server for EU service. We're currently looking into the issue.
Posted Nov 12, 2019 - 09:30 CET