Cloud Recording Service experience degraded performance

Incident Report for Angelcam

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 12:07 CET

Update

We have identified an issue with our recording infrastructure in the NA region. We're investigating the incident.
Posted Mar 14, 2026 - 10:23 CET

Identified

Our automated system detected degraded network performance. Fraction of camera streams might experience gaps in recordings.
Posted Mar 14, 2026 - 08:35 CET
This incident affected: Camera Cloud Recording (Cloud Recording).