Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 19, 2025 - 13:00 CET
Scheduled
We'll be updating a core component of our CDN during this time window. Degraded streaming performance and short stream outages should be expected.
Posted Mar 07, 2025 - 11:30 CET
This scheduled maintenance affected: Central Monitoring Stations (Video Verification, Video Patrolling), Angelcam Connectors (Camera Stream Connectivity, Stream Detector, Angelcam Connector for US, Angelcam Connector for EU), Web sites (My Angelcam), Camera Cloud Recording (Cloud Recording, Recording player for US, Recording player for EU), Notifications (Camera status health check), and Mobile application, Camera Broadcasting.