Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 12, 2025 - 16:00 CEST
Scheduled
We will be upgrading our EKS cluster to a newer version to maintain AWS standards and compatibilities.
Posted Jul 28, 2025 - 15:48 CEST
This scheduled maintenance affected: Central Monitoring Stations (Video Verification), Angelcam Connectors (Camera Stream Connectivity, Stream Detector, Angelcam Connector for US, Angelcam Connector for EU), Web sites (My Angelcam), Camera Cloud Recording (Cloud Recording, Recording player for US, Recording player for EU), and Notifications (Camera status health check).